PayPal Gateway Error

This topic contains 5 replies, has 3 voices, and was last updated by  Patrik 5 years, 10 months ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket
  • Author
    Posts
  • #1600

    Richard Parry
    Buyer
    Post count: 121

    Hello,

    I have an error being generated with the PayPal Pro payment gateway. I have the correct credentials from PayPal and I have a PayPal Pro account. I obtain the following error when payment is submitted.

    “Error: Paypal Pro payment error occurred. Security header is not valid”

    There was a similar error when I used Stripe. Do you know how this can be fixed please?

    Many thanks,

    Richard

    #1603

    Richard Parry
    Buyer
    Post count: 121

    After some tinkering, I now get the following error:

    “Error: Paypal Pro payment error occurred. DPRP is disabled for this merchant.”

    #1604

    Alex Rollin
    Moderator
    Post count: 27815

    https://www.paypal.com/us/smarthelp/article/why-did-i-get-direct-payment-recurring-payments-error-%E2%80%9Cdprp-is-disabled-for-this-merchant%E2%80%9D-ts2021

    
    
    
    Issue
    PayPal returned error 11586 - DPRP is disabled for this merchant.
    
    Cause
    The Direct Payment Recurring Payments product isn't enabled on your account.
    
    Solution
    You must determine your account version and take appropriate action.
    

    Login to Paypal and continue setup for recurring payments.

    #1608

    Richard Parry
    Buyer
    Post count: 121

    Thank you. Richard

    #1609

    Richard Parry
    Buyer
    Post count: 121

    I have both the older API and Payflow on my PayPal Pro account. Do I need DPRP or should I be using the Payflow Recurring Billing for use with your plugin? I do have recurring billing authorised – but this is not currently DPRP. Best wishes, Richard

    “Which recurring payments product is best for my account version?
    If you have PayPal Payments Pro, DPRP is the right product for you. To have it enabled on your account, contact PayPal Sales.

    PayPal Payflow Pro, our newest version of PayPal Payments Pro, is incompatible with DPRP. We suggest that PayPal Payflow Pro users use Payflow Recurring Billing – a newer product with the same functionality as DPRP.”

    #1610

    Patrik
    Moderator
    Post count: 1971

    Hi Richard,

    You need to have DPRP enabled on your PayPal account. You can contact PayPal support for that and they will help you out. Let me know if you get an error after activating the DPRP on your PayPal account.

    Regards,
    Patrik

Viewing 6 posts - 1 through 6 (of 6 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket